The legacy device(Glow, Glow-C, Awair V1) will be sunset from November 30, 2022.

Learn More

System Requirements

You will need the following to get started on your Awair Experience: 

  1. Wi-Fi Connection (Awair is only compatible with 2.4GHz)
  2. Awair app with active Awair account
  3. Smartphone or tablet with iOS 8 or later with BLE technology, or Android 4.3 or later. For more details, please read our Supporting devices

 This product may not be available in all areas. Click here to check availability and purchasing options.

Have more questions? Submit a request